CentOS 6.5 升级 PHP 到5.6

wordpress升级版本需要提高PHP的版本,所以只能做升级了,综合几个帖子的内容整理一下比较简单的操作方案。

  1. 首先先看下已安装的版本
    • php -v
  2. 升级之前需要卸载一下旧版本,不卸载直接安装新版会提示失败
    • yum remove php*
  3. 然后更新一下yum源
    • sudo yum install epel-release -y
  4. 最后安装 5.6版 php 和 php-fpm 以及一些其他扩展,按需选择
    • yum install php56w php56w-fpm php56w-mysql php56w-mbstring php56w-gd php56w-dom
    • 其中 php-fpm 是 nginx 里要用的 fast-cgi 进程管理器,重新安装后可能还需要重启一下fpm
    • /etc/init.d/php-fpm restart
    • 注:如果要升级php7,把上面命令中的 php56w 改为 php70w 即可
  5. 参考文章
    • https://www.cnblogs.com/savokiss/p/6259816.html
    • https://my.oschina.net/HeAlvin/blog/2050980

发表评论

电子邮件地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据