标签归档:Eclipse

eclipse velocity语法高亮

eclipse里面使用velocity的.vm文件确实是很难受的一件事情,IDEA里面用不存在这个问题,最直接的方法就是用htm编辑器打开,插件尝试装了好几个,没有满意的还是设置htm编辑器打开吧。

eclipse *.vm 文件,语法高亮:
设置文件打开时使用的编辑器

[code]
General>>Editors>>File Associations

General>>Content Types,选择Text>>Html

[/code]

点击Add,输入*.vm,保存。

Eclipse、Intellij idea格式化统一Eclipse Code Formatter

Eclipse、Intellij idea格式化结果不一样,导致长时间都是用两个开发工具,idea开发eclipse进行格式化。但是现在这个问题可以解决了。使用Eclipse Code Formatter。

具体的插件地址:http://plugins.jetbrains.com/plugin/6546?pr=idea&offset=15&max=15#comments_pan

Intellij idea:
1,安装插件:
网络安装:选择Setting =>Plugins=>Browse repositories,搜索Eclipse即可出现,点击左上角的Download and Install安装。安装之后重启Intellij,即可在Setting =>Eclipse Code Formatter找到配置项。
硬盘安装(推荐):Setting =>Plugins=>Install plugin from disk,选中下载好的安装包【EclipseFormatter.zip】安装,重启后生效;
2,配置插件:
选择Setting =>Eclipse Code Formatter,勾选Use the Eclipse-code-formatter,并在Eclipse Java Formatter config file选择Eclipse用的code-style.xml文件,这个选项会决定格式化代码的方式。
同时配置Import order的From File也为Eclipse用的code-style.xml文件,这个选项会决定组织import区域的方式。
3,使用插件
使用Intellij的格式化快捷键”Ctrl+ALT+L”即可进行格式化。如果出错会输出提示到Event Log里,如果看到’xxx formatted sucessfully by Eclipse code formatter’则表示格式化成功!

Missing artifact com.sun:tools:jar 1.5.0

刚开始使用eclipse,各种各样神奇的问题,确实很想吐槽。比如:

使用m2eclipse插件时,在pom.xml中添加struts2-core.jar包后,需要依赖java运行时的tools.jar进行依赖。
但是,此时eclipse无法读取tools包,出现如下错误:
Missing artifact com.sun:tools:jar 1.5.0

解决办法一:
手动配置pom.xml,添加一个dependency如下:

[xml]<dependency>
<groupId>com.sun</groupId>
<artifactId>tools</artifactId>
<scope>system</scope>
<systemPath>${JAVA_HOME}/../lib/tools.jar</systemPath>
</dependency>[/xml]

我在pom.xml添加如下代码后就解决了:

[xml]<dependency>
<groupId>com.sun</groupId>
<artifactId>tools</artifactId>
<version>1.5.0</version>
<scope>system</scope>
<systemPath>C:/Program Files/Java/jdk1.6.0_27/lib/tools.jar</systemPath>
</dependency> [/xml]

解决办法二:
首先,查看错误列表windows->Show View->Problems,在有以上问题的同时,还会出现该错误。
The container ‘Maven Dependencies’ references non existing library ‘C:\Documents and Settings\DELL\.m2\repository\com\sun\tools\1.5.0\tools-1.5.0.jar’
大致说:找不到该tools-1.5.0.jar。
所以将C:\Program Files\Java\jdk1.6.0_10\lib\目录下的tools.jar拷贝到C:\Documents and Settings\DELL\.m2\repository\com\sun\tools\1.5.0\目录下,并将tools.jar改名为tools-1.5.0.jar,并在pom.xml中作如下配置:

[xml]<dependency>
<groupId>com.sun</groupId>
<artifactId>tools</artifactId>
<version>1.5.0</version>
</dependency>[/xml]

第二种比较麻烦,推荐第一种吧。

转载地址:http://blog.csdn.net/jazz2013/article/details/8596198

eclipse maven 错误Errors occurred during the build

情景:
eclipse突然挂掉然后 maven 无法使用

错误信息:
Errors occurred during the build.
Error instantiating builder ‘org.eclipse.m2e.core.maven2Builder’.
Plug-in org.eclipse.m2e.core was unable to load class org.eclipse.m2e.core.internal.builder.MavenBuilder.
An error occurred while automatically activating bundle org.eclipse.m2e.core (524).
Plug-in org.eclipse.m2e.core was unable to load class org.eclipse.m2e.core.internal.builder.MavenBuilder.
An error occurred while automatically activating bundle org.eclipse.m2e.core (524).

解决方案:
google、百度之后的解决方案就是使用其他workspace的\.metadata\.plugins\org.eclipse.e4.workbench\workbench.xmi文件进行替换,第一次替换失败,再次替换成功了。